Forum Replies Created

Viewing 15 replies - 1 through 15 (of 26 total)
  • Thread Starter Geldnerd

    (@geldnerd)

    Hi Mat, thanks for your reply.

    All feeds passed the ‘Validate & Clean’ test in the Feed Categories, and the widget is not giving any error messages in the sidebar. I have tested all feeds manually just to make sure, and there are no issues with the feeds.

    Feedzy settings: Showing authore, date, time, no images, just the title. Showing 25 items.

    Inbetween, Feedzy upgraded to 3.7.4. Using that version, I cannot reproduce the problem anymore. I will mark it as resolved.

    Thread Starter Geldnerd

    (@geldnerd)

    OK, I got it working again with some issues. I will open a new support topic for that. But as the original issue (Feedzy widget not accessible in admin area) was resolved with the release of 3.7,3, I will mark this topic as Resolved.

    Thread Starter Geldnerd

    (@geldnerd)

    Just spoke to a fellow blogger and Feedzy user Uitklokken.

    He was on WordPress 5.7 updating to Feedzy 3.7.3. and everything worked fine. After that he did a manual upgrade to WordPress 5.8 and the Feedzy widget broke down, same symptoms as I have.

    So something seems to be not compatible between Feedzy 3.7.3 and WordPress 5.8?

    Thread Starter Geldnerd

    (@geldnerd)

    Furthermore, I cannot set a Title for the widget block.

    Thread Starter Geldnerd

    (@geldnerd)

    OK, so 3.7.3 gives me access to the widget. I can set it up. However, when updating the Widgets the system reports an error ‘not a valid JSON response’ (In dutch: Er was een fout. De reactie is geen geldige JSON-reactie.)

    The widget is not displaying on my site.

    Thread Starter Geldnerd

    (@geldnerd)

    And Please find the debug.log below.

    ——-

    [24-Aug-2021 06:18:19 UTC] PHP Notice:  WP_Scripts::localize werd <strong>verkeerd</strong> aangeroepen. De parameter <code>$l10n</code> moet een array zijn. Gebruik in plaats daarvan de functie <code>wp_add_inline_script()</code> om willekeurige gegevens aan scripts door te geven. Lees <a href="https://wporg.ibadboy.net/support/article/debugging-in-wordpress/">Foutopsporing in WordPress</a> voor meer informatie. (Dit bericht is toegevoegd in versie 5.7.0.) in /data/www/geldnerd.nl/www/wp-includes/functions.php on line 5535
    [24-Aug-2021 06:18:30 UTC] PHP Notice:  WP_Scripts::localize werd <strong>verkeerd</strong> aangeroepen. De parameter <code>$l10n</code> moet een array zijn. Gebruik in plaats daarvan de functie <code>wp_add_inline_script()</code> om willekeurige gegevens aan scripts door te geven. Lees <a href="https://wporg.ibadboy.net/support/article/debugging-in-wordpress/">Foutopsporing in WordPress</a> voor meer informatie. (Dit bericht is toegevoegd in versie 5.7.0.) in /data/www/geldnerd.nl/www/wp-includes/functions.php on line 5535
    [24-Aug-2021 06:18:41 UTC] PHP Notice:  wp_enqueue_script() werd <strong>verkeerd</strong> aangeroepen. "wp-editor" script should not be enqueued together with the new widgets editor (wp-edit-widgets or wp-customize-widgets). Lees <a href="https://wporg.ibadboy.net/support/article/debugging-in-wordpress/">Foutopsporing in WordPress</a> voor meer informatie. (Dit bericht is toegevoegd in versie 5.8.0.) in /data/www/geldnerd.nl/www/wp-includes/functions.php on line 5535
    [24-Aug-2021 06:18:45 UTC] PHP Fatal error:  Uncaught Error: Call to undefined function get_current_screen() in /data/www/geldnerd.nl/www/wp-content/plugins/feedzy-rss-feeds/includes/admin/feedzy-wp-widget.php:81
    Stack trace:
    #0 /data/www/geldnerd.nl/www/wp-includes/rest-api/endpoints/class-wp-rest-widget-types-controller.php(545): feedzy_wp_widget->form()
    #1 /data/www/geldnerd.nl/www/wp-includes/rest-api/endpoints/class-wp-rest-widget-types-controller.php(484): WP_REST_Widget_Types_Controller->get_widget_form()
    #2 /data/www/geldnerd.nl/www/wp-includes/rest-api/class-wp-rest-server.php(1140): WP_REST_Widget_Types_Controller->encode_form_data()
    #3 /data/www/geldnerd.nl/www/wp-includes/rest-api/class-wp-rest-server.php(987): WP_REST_Server->respond_to_request()
    #4 /data/www/geldnerd.nl/www/wp-includes/rest-api/class-wp-rest-server.php(414): WP_REST_Server->dispatch()
    #5 /data/www/geldnerd.nl/www/wp-includes/rest-api.php(370): WP_REST_Server->serve_request()
    #6 /data/www/geldnerd.nl/www/wp-includes/class-wp-hook.php(303): rest_api_loaded()
    #7 /data/www/gel in /data/www/geldnerd.nl/www/wp-content/plugins/feedzy-rss-feeds/includes/admin/feedzy-wp-widget.php on line 81
    [24-Aug-2021 06:18:46 UTC] PHP Notice:  WP_Scripts::localize werd <strong>verkeerd</strong> aangeroepen. De parameter <code>$l10n</code> moet een array zijn. Gebruik in plaats daarvan de functie <code>wp_add_inline_script()</code> om willekeurige gegevens aan scripts door te geven. Lees <a href="https://wporg.ibadboy.net/support/article/debugging-in-wordpress/">Foutopsporing in WordPress</a> voor meer informatie. (Dit bericht is toegevoegd in versie 5.7.0.) in /data/www/geldnerd.nl/www/wp-includes/functions.php on line 5535
    [24-Aug-2021 06:18:46 UTC] PHP Notice:  WP_Scripts::localize werd <strong>verkeerd</strong> aangeroepen. De parameter <code>$l10n</code> moet een array zijn. Gebruik in plaats daarvan de functie <code>wp_add_inline_script()</code> om willekeurige gegevens aan scripts door te geven. Lees <a href="https://wporg.ibadboy.net/support/article/debugging-in-wordpress/">Foutopsporing in WordPress</a> voor meer informatie. (Dit bericht is toegevoegd in versie 5.7.0.) in /data/www/geldnerd.nl/www/wp-includes/functions.php on line 5535
    [24-Aug-2021 06:18:46 UTC] PHP Notice:  WP_Scripts::localize werd <strong>verkeerd</strong> aangeroepen. De parameter <code>$l10n</code> moet een array zijn. Gebruik in plaats daarvan de functie <code>wp_add_inline_script()</code> om willekeurige gegevens aan scripts door te geven. Lees <a href="https://wporg.ibadboy.net/support/article/debugging-in-wordpress/">Foutopsporing in WordPress</a> voor meer informatie. (Dit bericht is toegevoegd in versie 5.7.0.) in /data/www/geldnerd.nl/www/wp-includes/functions.php on line 5535
    [24-Aug-2021 06:18:46 UTC] PHP Notice:  WP_Scripts::localize werd <strong>verkeerd</strong> aangeroepen. De parameter <code>$l10n</code> moet een array zijn. Gebruik in plaats daarvan de functie <code>wp_add_inline_script()</code> om willekeurige gegevens aan scripts door te geven. Lees <a href="https://wporg.ibadboy.net/support/article/debugging-in-wordpress/">Foutopsporing in WordPress</a> voor meer informatie. (Dit bericht is toegevoegd in versie 5.7.0.) in /data/www/geldnerd.nl/www/wp-includes/functions.php on line 5535
    [24-Aug-2021 06:18:47 UTC] PHP Notice:  WP_Scripts::localize werd <strong>verkeerd</strong> aangeroepen. De parameter <code>$l10n</code> moet een array zijn. Gebruik in plaats daarvan de functie <code>wp_add_inline_script()</code> om willekeurige gegevens aan scripts door te geven. Lees <a href="https://wporg.ibadboy.net/support/article/debugging-in-wordpress/">Foutopsporing in WordPress</a> voor meer informatie. (Dit bericht is toegevoegd in versie 5.7.0.) in /data/www/geldnerd.nl/www/wp-includes/functions.php on line 5535
    [24-Aug-2021 06:18:47 UTC] PHP Notice:  WP_Scripts::localize werd <strong>verkeerd</strong> aangeroepen. De parameter <code>$l10n</code> moet een array zijn. Gebruik in plaats daarvan de functie <code>wp_add_inline_script()</code> om willekeurige gegevens aan scripts door te geven. Lees <a href="https://wporg.ibadboy.net/support/article/debugging-in-wordpress/">Foutopsporing in WordPress</a> voor meer informatie. (Dit bericht is toegevoegd in versie 5.7.0.) in /data/www/geldnerd.nl/www/wp-includes/functions.php on line 5535
    [24-Aug-2021 06:18:50 UTC] PHP Notice: A feed could not be found at <code>https://www.financelle.nl/feed/</code>; the status code is <code>304</code> and content-type is <code></code> in /data/www/geldnerd.nl/www/wp-includes/class-simplepie.php on line 1728
    [24-Aug-2021 06:18:52 UTC] PHP Notice:  WP_Scripts::localize werd <strong>verkeerd</strong> aangeroepen. De parameter <code>$l10n</code> moet een array zijn. Gebruik in plaats daarvan de functie <code>wp_add_inline_script()</code> om willekeurige gegevens aan scripts door te geven. Lees <a href="https://wporg.ibadboy.net/support/article/debugging-in-wordpress/">Foutopsporing in WordPress</a> voor meer informatie. (Dit bericht is toegevoegd in versie 5.7.0.) in /data/www/geldnerd.nl/www/wp-includes/functions.php on line 5535
    [24-Aug-2021 06:18:52 UTC] PHP Notice: A feed could not be found at <code>https://www.financelle.nl/feed/</code>; the status code is <code>304</code> and content-type is <code></code> in /data/www/geldnerd.nl/www/wp-includes/class-simplepie.php on line 1728
    [24-Aug-2021 06:18:57 UTC] PHP Notice:  WP_Scripts::localize werd <strong>verkeerd</strong> aangeroepen. De parameter <code>$l10n</code> moet een array zijn. Gebruik in plaats daarvan de functie <code>wp_add_inline_script()</code> om willekeurige gegevens aan scripts door te geven. Lees <a href="https://wporg.ibadboy.net/support/article/debugging-in-wordpress/">Foutopsporing in WordPress</a> voor meer informatie. (Dit bericht is toegevoegd in versie 5.7.0.) in /data/www/geldnerd.nl/www/wp-includes/functions.php on line 5535
    [24-Aug-2021 06:19:02 UTC] PHP Notice:  WP_Scripts::localize werd <strong>verkeerd</strong> aangeroepen. De parameter <code>$l10n</code> moet een array zijn. Gebruik in plaats daarvan de functie <code>wp_add_inline_script()</code> om willekeurige gegevens aan scripts door te geven. Lees <a href="https://wporg.ibadboy.net/support/article/debugging-in-wordpress/">Foutopsporing in WordPress</a> voor meer informatie. (Dit bericht is toegevoegd in versie 5.7.0.) in /data/www/geldnerd.nl/www/wp-includes/functions.php on line 5535
    [24-Aug-2021 06:19:05 UTC] PHP Notice:  WP_Scripts::localize werd <strong>verkeerd</strong> aangeroepen. De parameter <code>$l10n</code> moet een array zijn. Gebruik in plaats daarvan de functie <code>wp_add_inline_script()</code> om willekeurige gegevens aan scripts door te geven. Lees <a href="https://wporg.ibadboy.net/support/article/debugging-in-wordpress/">Foutopsporing in WordPress</a> voor meer informatie. (Dit bericht is toegevoegd in versie 5.7.0.) in /data/www/geldnerd.nl/www/wp-includes/functions.php on line 5535
    [24-Aug-2021 06:19:14 UTC] PHP Notice:  WP_Scripts::localize werd <strong>verkeerd</strong> aangeroepen. De parameter <code>$l10n</code> moet een array zijn. Gebruik in plaats daarvan de functie <code>wp_add_inline_script()</code> om willekeurige gegevens aan scripts door te geven. Lees <a href="https://wporg.ibadboy.net/support/article/debugging-in-wordpress/">Foutopsporing in WordPress</a> voor meer informatie. (Dit bericht is toegevoegd in versie 5.7.0.) in /data/www/geldnerd.nl/www/wp-includes/functions.php on line 5535
    [24-Aug-2021 06:19:53 UTC] PHP Notice:  WP_Scripts::localize werd <strong>verkeerd</strong> aangeroepen. De parameter <code>$l10n</code> moet een array zijn. Gebruik in plaats daarvan de functie <code>wp_add_inline_script()</code> om willekeurige gegevens aan scripts door te geven. Lees <a href="https://wporg.ibadboy.net/support/article/debugging-in-wordpress/">Foutopsporing in WordPress</a> voor meer informatie. (Dit bericht is toegevoegd in versie 5.7.0.) in /data/www/geldnerd.nl/www/wp-includes/functions.php on line 5535
    Thread Starter Geldnerd

    (@geldnerd)

    Yes, I am still encountering issues. Please find enclosed two screenshots. The first one has the error message (in dutch, sorry) saying “Block ‘feedzy_wp_widget’ contains errors and will therefore not function properly. Use the developer tool for more details.” The other one shows the Feedzy widget block, with a continuously rotating circle.

    Further info: Uninstalling and reinstalling the Feedzy plugin did not resolve the issue. And I am using the OceanWP theme.

    Thread Starter Geldnerd

    (@geldnerd)

    Thank you!

    Thread Starter Geldnerd

    (@geldnerd)

    Thank you for your reply.

    Thread Starter Geldnerd

    (@geldnerd)

    Hi @mikeyboo , 2FAS gave me the following reaction: “`This cannot be fixed as long as WordPress’s core is not dependent on dependencies (installed by php Composer dependency manager).
    In short, many plugins use external libraries which come in different versions, e.g. 2FAS Prime and WP RSS use PHP-DI libraries so one of these plugins will not work. We decided that we will not struggle with it anymore and only display an error message (previously, as you mentioned, the user got an error and the whole website did not work properly).
    Besides, you can meet many other plugins that also won’t work because they also use this library.
    In summary, this cannot be solved at the plugin level.`”

    What is your opinion on this?

    Thread Starter Geldnerd

    (@geldnerd)

    Submitted a question over at the 2FAS team as well.

    Thread Starter Geldnerd

    (@geldnerd)

    The plugin upgraded itself to 3.7.2 this night. However, the error message in the widget remains the same, the upgrade did not resolve it.

    Thread Starter Geldnerd

    (@geldnerd)

    Thank you very much for your reply. I am looking forward to that update.

    Thread Starter Geldnerd

    (@geldnerd)

    That resolved the issue, thanks.

    Thread Starter Geldnerd

    (@geldnerd)

    Thanks.

Viewing 15 replies - 1 through 15 (of 26 total)