Support » Plugin: WordPress Live Webcam Widget & Shortcode » Username and password in url is ignored

Viewing 6 replies - 1 through 6 (of 6 total)
  • Hi Pakka and other readers,
    thats quite a funny timing! Untill yesterday, I was searching a solution for just the same problem: I am using a Hikvision camera which always asked for username and passwort… After hours of web research, I found a working solution for my cam in another forum. The solution is to add the username:password as BASE64 coded string. For my camera, it’s
    [webcam url=”http://fotofabritz.ddns.net:85/streaming/channels/1/picture/?auth=R2FzdDpnYXN0cHc=” refresh=”60″ alt=”Bild der Kirchturm-Kamera”]

    The sheme is http://IP/streaming/channels/1/picture/?auth=XXXX

    So, in my case the part after auth= is standing for Gast:gastpw as username:password in Base64 encoding (online encoding can be easely found in the web). I made a special user called “Gast” with password “gastpw” with lower admittance on the cam.
    Next days, the cam will be installed on a church. Hope this will work for you as well!

    Greetings from Germany,Klaus

    • This reply was modified 3 years, 9 months ago by egosum.
    • This reply was modified 3 years, 9 months ago by egosum.
    Thread Starter pakka

    (@pakka)

    awesome!
    exactly what I was looking for!

    Danke Klaus 🙂

    Thread Starter pakka

    (@pakka)

    okay…. never post before you check it 😉
    With my Hikvision cam this phrase auth=basecode does not work… :((
    I found a thread in german where it is discussed. they suggest to use “http://Kamera-IP/Streaming/channels/1/picture?auth=AUTH-String” but my ds-2cd2085 still asks for user and password.

    OK, it’s a pitty, but let’s work on it. If you wanna do, you can send me links to your cam (plus name:pwd for guest account) to “foto fabritz @ gmail. com” (delete all spaces).
    Second, remember, that the auth code is case sensitive.
    Third, in your example there is an slash missing between picture?auth. Must be …picture/?auth… as far as i know.
    Fourth, did you check the link in pure browser, copying the complete code to the adress bar of your brouwser?
    Fifth, there are three versions of givin the name:password to the cam:
    a) http://name:password@ip.port/channels….
    b) http://ip.port/channels…html?name=user&pwd=password
    c) The auth-Code version described above.
    I found it here: https://knx-user-forum.de/forum/supportforen/smarthome-py/1030144-python-urllib-f%C3%BCr-kamera-mit-username-passwort-hikvision
    Six: There is an setting inside the cam-firmware regarding on basic authethifacation or something like that. Unfortunatly, I can’t look inside my camera, because the one ist on the tower of the church meanwhile, but not working (by fault of the router…)! So I have to step up there to have a look on it to get the router & cam working. After checking this, I will give you another hint here.
    Good luck, Klaus

    OK, on my firmware for Hikvsion DS-2CD2032-I there is an tab “Konfiguration” with a subtab “Authentifizierung”. There are two fields, one for RTSP and one for Web, both set to “basic”.

    Thread Starter pakka

    (@pakka)

    Ich can choose between digest and digest/basic.
    And took second one for rstp and Web.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Username and password in url is ignored’ is closed to new replies.