Support » Plugin: Best WordPress Gallery Plugin – FooGallery » Text not showing after update to FooGallery version 2

  • Resolved newage2019

    (@newage2019)


    Hello!

    After updating to version 2 caption text is not showing in full, as it was before. Now it gets cropped, shows only the first line, see https://ibb.co/6DdqZgP

    • This topic was modified 5 months, 2 weeks ago by newage2019.
    • This topic was modified 5 months, 2 weeks ago by newage2019.
    • This topic was modified 5 months, 2 weeks ago by newage2019.
    • This topic was modified 5 months, 2 weeks ago by newage2019.

    The page I need help with: [log in to see the link]

Viewing 11 replies - 1 through 11 (of 11 total)
  • Plugin Author bradvin

    (@bradvin)

    hi @newage2019

    The caption is made up of 2 parts – the title and description.
    Try change the caption so that it outputs the text as a description and do not have a title. The title is always cropped to single line, but the description can be multiple lines long.

    Thread Starter newage2019

    (@newage2019)

    Nope, does not work. The description does not show on mouse over or under the picture.
    is there a way to downgrade to the old working version of Foo Gallery?

    • This reply was modified 5 months, 2 weeks ago by newage2019.
    Plugin Support elviiso

    (@elviiso)

    Hi @newage2019

    Thanks for getting back to us with that update.

    Just to confirm, could you kindly share the gallery page where this issue’s occurring so that we can have a look at it from our end? Thanks in advance for doing so.

    Also, could you kindly enable FooGallery Debug Comments for us so that we can be able to effectively assist you with this? To do so, kindly navigate to FooGallery -> Settings -> Advanced and click on the “Enable Debug” checkbox option.

    This will help us investigate this issue further. Once done, kindly let me know.

    Thread Starter newage2019

    (@newage2019)

    This is the page with the gallery: https://blog.beinsa.info/2021/12/03/education/
    I enabled debugging.

    Plugin Support elviiso

    (@elviiso)

    Hi @newage2019

    If you want the whole text to appear, a workaround would be to go to the FooGallery Gallery settings/config section of that particular gallery where you’ll click on the “Captions” tab and set Title to None and Description to Attachment Title as shown in the image linked below, or whichever section you want the text to be drawn from: https://prnt.sc/238qkou

    Hope this helps.

    Thread Starter newage2019

    (@newage2019)

    Hi!
    I changed it but now the text shows over the image and covers it completely: https://ibb.co/S7ncPqk
    When I click on the image and show it on full screen, the text is still truncated.

    Plugin Support elviiso

    (@elviiso)

    Hi @newage2019

    In that case, you’ll have to shorten the title since it is layered over the image by default as you observed.

    Thread Starter newage2019

    (@newage2019)

    Whathever I do, it does not affect the text under the image, after I open it – it is always truncated.
    Is there any way to downgrade FooGallery to the old working version?

    Plugin Support elviiso

    (@elviiso)

    @newage2019

    The scripts making up the Captions feature have never been modified/updated for over a year now and so even if you do downgrade, I’m not expecting any changes and the text will still be truncated. The only simple solution is using a shorter title.

    With that said, here’s a guide that you can follow if you want to downgrade the plugin to a much lower version: https://quadlayers.com/downgrade-plugins-and-themes-wordpress/

    Hope this helps.

    Thread Starter newage2019

    (@newage2019)

    The site has been up for years and it always worked fine – full text was showing on the bottom of the image, when I click it and open it on full screen. The problem appeared after I upgraded the FooGallery plugin.

    Thread Starter newage2019

    (@newage2019)

    Unfortunately I had to remove FooGallery and switch to NextGEN. Now it all looks fine, text is not truncated: https://ibb.co/WDskM46

Viewing 11 replies - 1 through 11 (of 11 total)
  • You must be logged in to reply to this topic.