Support » Plugin: RSS Aggregator by Feedzy - Powerful WP Autoblogging and News Aggregator » PHP Fatal error: Uncaught Error: Call to undefined function wp_use_widgets_bloc

  • Resolved kiudex

    (@kiudex)


    I want to use the Feedzy plugin with Gutenberg but I’m getting a fatal error as soon as I activate the plugin and try to edit a page with the Block editor. On Elementor pages it works though.

    This is the error I get in the debug.log:

    26-Aug-2021 08:20:19 UTC] PHP Fatal error:  Uncaught Error: Call to undefined function wp_use_widgets_block_editor() in /root-folder/sequoya.kiudex.de/wp-content/plugins/feedzy-rss-feeds/includes/gutenberg/feedzy-rss-feeds-gutenberg-block.php:63
    Stack trace:
    #0 /root-folder/wp-includes/class-wp-hook.php(292): Feedzy_Rss_Feeds_Gutenberg_Block->feedzy_gutenberg_scripts('')
    #1 /root-folder/wp-includes/class-wp-hook.php(316): WP_Hook->apply_filters(NULL, Array)
    #2 /root-folder/wp-includes/plugin.php(484): WP_Hook->do_action(Array)
    #3 /root-folder/wp-admin/edit-form-blocks.php(409): do_action('enqueue_block_e...')
    #4 /root-folder/wp-admin/post.php(187): require('/www/htdocs/w00...')
    #5 {main}
      thrown in /root-folder/wp-content/plugins/feedzy-rss-feeds/includes/gutenberg/feedzy-rss-feeds-gutenberg-block.php on line 63

    This makes the plugin unusuable with the Block Editor for me.

    PHP Version: 7.4.19
    WP Version: 5.7.2
    Feedzy Plugin Version: 3.7.3

    • This topic was modified 1 month, 3 weeks ago by kiudex.
Viewing 8 replies - 1 through 8 (of 8 total)
  • Mat

    (@mateithemeisle)

    Hello @kiudex,

    Thank you for using Feedzy and for reaching out!

    Our developers just released a new version for Feedzy (3.7.4) that includes a fix for this error.

    Can you please update the plugin and let us know if it fixed it for you?

    Thank you and have an amazing day!

    I am using Version 3.7.4 and still receive the error. The offending function is still present.

    [02-Sep-2021 19:46:58 UTC] PHP Fatal error:  Uncaught Error: Call to undefined function wp_use_widgets_block_editor() in /dom30170/wp-content/plugins/feedzy-rss-feeds/includes/gutenberg/feedzy-rss-feeds-gutenberg-block.php:63
    Stack trace:
    #0 /wordpress-versions/5.7.2/wp-includes/class-wp-hook.php(292): Feedzy_Rss_Feeds_Gutenberg_Block->feedzy_gutenberg_scripts('')
    #1 /wordpress-versions/5.7.2/wp-includes/class-wp-hook.php(316): WP_Hook->apply_filters(NULL, Array)
    #2 /wordpress-versions/5.7.2/wp-includes/plugin.php(484): WP_Hook->do_action(Array)
    #3 /wordpress-versions/5.7.2/wp-admin/edit-form-blocks.php(409): do_action('enqueue_block_e...')
    #4 /wordpress-versions/5.7.2/wp-admin/post.php(187): require('/wordpress-vers...')
    #5 {main}
      thrown in /dom30170/wp-content/plugins/feedzy-rss-feeds/includes/gutenberg/feedzy-rss-feeds-gutenberg-block.php on line 63

    Hey @mateithemeisle

    any update on this issue? I’ve got the same behaviour with version 3.7.4 and 3.7.5 on my site when I try to create a new post.

    Regards, Jack

    Mat

    (@mateithemeisle)

    Hello @dutchmanjack / @jemo ,

    I am sorry to hear about the difficulties encountered!

    Seems like these errors are tied to the WP environment or PHP version from your websites as I couldn’t reproduce it myself.

    I see you are using WP 5.7.2 but can you please let us know what PHP version you are using along with settings of the feed and feed URL(in case no sensitive data is there)?

    I am asking for this info so I can try and replicate the issue on a test instance and forward it to our developers in case we are dealing with an actual issue!

    Thank you for your collaboration and for helping us get to the bottom of thi!

    I’m using WP v5.7.2, PHP v7.4, and NGINX on Pagely.

    This seems to be related:
    https://github.com/WordPress/gutenberg/issues/14012

    I was getting the same error, and looked over the docs for the function wp_use_widgets_block_editor()… the code says this function was added in WP version 5.8.0.

    So if a site isn’t updated to WP 5.8 yet, then this function (that Feedzy is using) would be undefined, resulting in a fatal error.

    Confirmed: updating the site to WP 5.8 resolved the error on my site.

    Hey @mateithemeisle

    I‘m using WP 5.7.2 and PHP 7.4.23 on an Apache Server.
    In case you still need the feed URL, please tell me.

    Thanks
    Jack

    Hi @kiudex, @jemo, @dutchmanjack and @jasontremblay!

    @jasontremblay you are right, thank you for pointing this out! The issue has to do with the version of WordPress used, everything works properly on WordPress 5.8, but the fatal error appears with WordPress 5.7. Please make sure you use the latest version of WordPress.

    Thank you and have a nice day!

Viewing 8 replies - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.