Support » Plugin: Elementor Custom Skin » Loop Layout issue with astra theme

  • Resolved ToTTi

    (@formgarten)


    I really have issues with a customer page that I can’t reproduce. I use ELE Custom Skin Pro and made a loop for a company list to show up. I already did that on another site using the generatepress theme. Now on another project I use the astra theme and I’m running into layout issues: there’s a huge space all around my layout snippet. What ever I try to change in the astra layout settings, nothing is taking effect. Also the layout settings (padding: 0) inside the loop file itself doesn’t change anything. I forced full width on the loop template section also. It’s driving me mad as it stops me getting further with the whole project.

    Any ideas? I haven’t got anymore 🙁

    • This topic was modified 1 year, 10 months ago by ToTTi.
Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Author dudaster

    (@dudaster)

    Please take a look at the astra css that it overwrites some rules

    hello
    At first I apologize for not knowing English well.
    I have the same issue.
    i am also using astra.
    we created an elementor section and put it in astra sidebar aria by this way:
    wp admin >> Appearance >> widget >>> elementor Library

    in that section i have this parts:
    1- elementor heading widget
    2- elementor post widget (using your plugin for skin)
    3- crocoblock jetblog smart-posts-listing widget

    The issue only appears in number 2

    Important note:
    we design a single template for some taxonomies using elementor pro
    this problem appears just in posts that are using astra single template:
    mojtabatehrani.com\join-us

    those posts that sre using elementor single template have not this problem:
    mojtabatehrani.com\insta-page-change

    Thread Starter ToTTi

    (@formgarten)

    Hi folks,

    sorry, I’ve forgotten to post the solution provided by Brainstormforce (Astra) itself. Here’s the original statement that was a solution:

    The Archive page that you have used as your default page for Partner list should be customized accordingly. You can do it with the Spacing module in the Astra Pro addon.

    Spacing Addon allows you to manage the margin and padding for various elements available with Astra. Default values for the theme will be overwritten by the values entered with Spacing Addon settings.

    Change it in Customizer > Global > Container > Spacing > Inside Container.

    Please read these article to know more about Spacing in Astra – https://wpastra.com/docs-category/astra-pro-modules/spacing/

    hello
    a have astra pro but
    this is not good solution.
    we need that spacing for post entry Container and We cannot delete it.
    if i set that spacing to 0,
    True, sidebar inner padding will remove but also remove for post entry Container.
    and it is because of classes that plugin call:
    .ast-separate-container .ast-article-post, .ast-separate-container .ast-article-single

    • This reply was modified 1 year, 9 months ago by payam.
    Thread Starter ToTTi

    (@formgarten)

    Sorry to hear that. For me it was okay as I don’t need the astra spacing controls at all as I use Elementor for my whole layout. Maybe you should contact brainstormforce as I did, too, and refer to that ticket here. Maybe they’ve another idea to help you out.

    hello again
    i think your your suggestion is not a solution
    it is a hack
    and problem still is related to plugin
    Maybe it’s better to change this topic to “not resolved”

    Plugin Author dudaster

    (@dudaster)

    /* Fix astra css issues */
    
    .ecs-post-loop .ast-article-single{
        background-color: none;
        border-bottom:none;
        margin: 0;
        padding: 0;
    }
Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Loop Layout issue with astra theme’ is closed to new replies.