Support » Plugin: Redis Object Cache » Issue with “Connection refused”

  • Resolved Pengi123

    (@pengi123)


    Hi

    I am using Plesk and I try to install Redis using this guide
    https://www.plesk.com/blog/guides/optimize-wordpress-redis-docker/
    but I only have “Redis” official I don’t see bitnami/redis image.

    I try to install “Redis” but on my configurations, I don’t have all variables like REDIS_PASSWORD, so I add it manually, but after I add 2 lines of code in a config file in wp I see that Redis cant connect
    Errors: [
    “Connection refused”
    ]

    I check on the Plesk side and I see that my Redis working, but for some reasons cant connect. I am not sure how to fix the issue?

    • This topic was modified 7 months, 2 weeks ago by Pengi123.
    • This topic was modified 7 months, 2 weeks ago by Pengi123.
Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Author Till Krüss

    (@tillkruess)

    You’ll need to find out what the host and port of your Redis Server is. Your hosting provider can assist you with that.

    Afterwards set the WP_REDIS_HOST and WP_REDIS_PORT in your wp-config.php.

    In my case the issue was in the redis docker settings.
    It was set to automatic port mapping, however that had to be disabled in my case.
    I then set it to internal and external 6379, then it was working immediately.

    • This reply was modified 3 months, 2 weeks ago by gabri85.
Viewing 2 replies - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.