Support » Plugin: Contact Form by WPForms - Drag & Drop Form Builder for WordPress » How do I remove extra text added in emails?

Viewing 15 replies - 1 through 15 (of 18 total)
  • Plugin Support Prashant Rai

    (@prashantrai)

    Hey @ildomandatore – Thanks for reaching out!

    When you have some time, can you please check if the specific text is added under Settings > Notifications > Email Message in the form builder? For more details, please see our guide here.

    Kindly,

    Thread Starter ildomandatore

    (@ildomandatore)

    {all_fields}

    Please, next time tell the full path. I had to go to Wpforms -> All Forms -> Edit. And after the path you said. Luckily I got there on my own, but it’s the first time I’ve had this insight while working on WordPress.

    Plugin Support Prashant Rai

    (@prashantrai)

    Hey @ildomandatore,

    Thanks for following up on this ticket, and I apologize for the confusion!

    I took another look at the screenshot you’ve shared, and it seems that the word Write is the field label that you’ve added to the form after the email field. When you have some time, can you please temporarily rename the Write field to something else, and see if the same test is still showing up in the email notification?

    Kindly,

    Thread Starter ildomandatore

    (@ildomandatore)

    Plugin Support Prashant Rai

    (@prashantrai)

    Hey @ildomandatore- Thanks for sharing the screenshot, looking at the screenshot it does seems that the word Write is coming from the field label. At this moment, you may consider renaming the word or including some additional words to give context to avoid any user confusion. I apologize, we currently don’t have the option to exclude field label when you’re using the {all_fields} smart tag.

    However, as a workaround, you can use an individual field ID along with some custom HTML in the notification which will allow you to exclude the Write text from the notifications. Here’s the step you can follow:

    Go to WPForms > All Forms, and click on the form which you would like to edit.
    Under Settings > Notifications > Email Message, remove {all_fields} smart tag, and add custom HTML in following format:

    <strong></strong>: {field_id="0"}
    <strong>Hello</strong>: {field_id="10"}

    Here, you’ll need to replace 0 and 10 with the field ids of the field. In the above code, you would notice between there’s no text. That’s the format you can use to hide the Write text.

    You’ll need to add the HTML for all the fields in the form.

    Kindly,

    Thread Starter ildomandatore

    (@ildomandatore)

    Where do I find the numbers? And why must there be a text? Wasn’t a nice empty field better?

    Plugin Support Prashant Rai

    (@prashantrai)

    Hey @ildomandatore – I agree that an empty field option would be handy and it’s on our developer’s radar. In the meantime, you can consider the workaround I shared above. To find the number of the Field, you can take a look at our documentation here.

    Kindly,

    Thread Starter ildomandatore

    (@ildomandatore)

    But are we sure we are talking about the same thing? If you show me a guide on IDs it is clear that we have not understood each other in some way. I get emails with the word Write with their text in the email. If I have to make changes to have problems, I do nothing and ignore the word before the text of whoever contacted me. There is no point in reading “spam words” before each email. Is the first field always an email? Why do I have to read the word Email ….?

    Plugin Support Prashant Rai

    (@prashantrai)

    Hey @ildomandatore – The first field need not be Email, it’s totally up to your requirement. Most of the users like to have Name as the first field. Having said that, I assist you better, I would like to take a step back, and when you get a chance, can you please share the export file of your form? That will help me to assist you better.

    Kindly,

    Thread Starter ildomandatore

    (@ildomandatore)

    Now I have downloaded the Json file, what do I do?

    Plugin Support Prashant Rai

    (@prashantrai)

    Hey @ildomandatore – Can you please share the json file using file-sharing applications like Googe Drive or Dropbox so I can take a closer look?

    Kindly,

    Thread Starter ildomandatore

    (@ildomandatore)

    Plugin Support Prashant Rai

    (@prashantrai)

    Hey @ildomandatore – Thanks for sharing the form export file.

    I imported the file, and I was able to replicate it wherein the text Write shows because it’s added in the form field. In this case, if you would like to not have them in the email notification, I would suggest you please follow the steps I shared in my reply here.

    Kindly,

    Thread Starter ildomandatore

    (@ildomandatore)

    I’m confused.

    Plugin Support Prashant Rai

    (@prashantrai)

    Hey @ildomandatore – When you get a chance, can you please share some more details so I can point you in the right direction? Also, can you please confirm if you’ve tried the solution I shared on May 23rd?

    Kindly,

Viewing 15 replies - 1 through 15 (of 18 total)
  • You must be logged in to reply to this topic.