Support » Plugin: XML Sitemap & Google News » How can I remove sitemap-author.xml?

  • Resolved usaco

    (@usaco)


    I’ve unchecked “Include authors” checkbox.
    But sitemap-author.xml still exists.
    How can I remove it?

Viewing 6 replies - 1 through 6 (of 6 total)
  • Hi, it may be that your sitemap is cached by the browser, a cache plugin or a server site cache. Check again, this time appending the URL with something like ?nocache123 (change the numbers when re-verifying)

    Thread Starter usaco

    (@usaco)

    Thanks, @ravanh
    I accessed sitemap-author.xml with the browser that I don’t usually use.
    But that XML is shown.

    Thread Starter usaco

    (@usaco)

    And I also use W3 Total Cache.

    Thread Starter usaco

    (@usaco)

    I deactivated the cache plugin, cleared the browser cache, and accessed sitemap-author.xml with a parameter again.
    But it’s still shown.

    Ok, now I see what you mean. The URL sitemap-author.xml is still accessible even when the option Include Authors is off. That option option controls whether the sitemap is included in the sitemap index /sitemap.xml or not. When switched off, the sitemap should not be in the index.

    It does indeed not disable the author sitemap completely. Make sure you submit the main sitemap index to search engines, not each sitemap individually.

    I’ll consider this a feature request (disabling “inactive” sitemaps completely) for the next release 🙂

    Thread Starter usaco

    (@usaco)

    @ravanh
    Thanks!
    I got it. I expect the next version.

Viewing 6 replies - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.