Support » Plugin: Best WordPress Gallery Plugin – FooGallery » Foo Galleries randomly stop working on my page

  • Resolved jamespond

    (@jamespond)


    I’ve been having this issue for months now, went through several different updates for WP and FooGallery and none of them helped. I don’t have any cache plugins on my website or anything else I can think of that could cause this issue.

    Most of the the galleries work fine, but every now and then some will simply stop loading thumbnails. The only solution to this is to go to the Gallery Edit option and click UPDATE even without making any changes.

    Sometimes it will be one or two images out of the whole gallery, sometimes most of them. It’s completely random.

    Here’s an example of one of them:

    https://imgur.com/B9EICjb

    https://imgur.com/a/FQLRsx3

    https://www.forgottenchernobyl.net/old-pripyat-checkpoint-and-lead-glass-windows

    Any help would be greatly appreciated.

    • This topic was modified 2 months ago by jamespond.

    The page I need help with: [log in to see the link]

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Author steveush

    (@steveush)

    Hi @jamespond,

    The core issue is that the gallery is set to perform lazy loading however something is stripping the required data- attributes off of the <img/> elements and setting the src directly. As the JS is expecting to lazy load the images and there is no data- attributes it instantly fails and displays the error icon.

    A quick fix would be to simply disable lazy loading in FooGallery and then everything should work as expected. Lazy loading is currently not being performed anyway due to whatever is modifying the markup.

    The longer fix would be trying to find what is modifying the markup and either disabling it or excluding FooGallery images from it.

    Thanks
    Steve

    Thread Starter jamespond

    (@jamespond)

    Hi Steve,

    Thank you so much, it fixed the issue! My hosting can easily handle the extra traffic so I will just leave it disabled.

    Thanks,
    Kamil

Viewing 2 replies - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.