• Hi all,

    I am encountering a problem with the WappPress plugin. The installation seems to work fine but whenever I try to activate the plugin I get a Critical Error (“There has been a critical Error on your website).

    My WordPress version is 5.8.1. I am using the Astra theme (version 3.7.3).

    Here are the error logs I obtain:

    lne 51 of file .../wp-content/plugins/wapppress-builds-android-app-for-website/includes/wappPress_theme_switcher.php. Error message : Uncaught Error: Undefined constant "WAPPPRESS_SETTINGS" in .../wp-content/plugins/wapppress-builds-android-app-for-website/includes/wappPress_theme_switcher.php:51
    Stack trace:
    #0 .../wp-content/plugins/wapppress-builds-android-app-for-website/includes/wappPress_theme_switcher.php(18): wappPress_theme_switcher->wappPress_customizer()
    #1 .../wp-includes/class-wp-hook.php(303): wappPress_theme_switcher->admin_switch_theme('')
    #2 .../wp-includes/class-wp-hook.php(327): WP_Hook->apply_filters(NULL, Array)
    #3 .../wp-includes/plugin.php(470): WP_Hook->do_action(Array)
    #4 .../wp-settings.php(441): do_action('plugins_loaded')
    #5 .../wp-config.php(84): require_once('/home/...')
    #6 .../wp-load.php(50): require_once('/home/...')
    #7 .../wp-admin/admin.php(34): require_once('/home/...')
    #8 .../wp-admin/plugins.php(10): require_once('/home/...')
    #9 {main}
      thrown

    Any idea what may be causing the issue?

    Thank you in advance.

    Ronan

    • This topic was modified 5 months, 2 weeks ago by Ronan Fruit.
    • This topic was modified 5 months, 2 weeks ago by Ronan Fruit.
    • This topic was modified 5 months, 2 weeks ago by Ronan Fruit.
    • This topic was modified 5 months, 2 weeks ago by Ronan Fruit.
    • This topic was modified 5 months, 2 weeks ago by Ronan Fruit.
    • This topic was modified 5 months, 2 weeks ago by Ronan Fruit.

    The page I need help with: [log in to see the link]

Viewing 2 replies - 1 through 2 (of 2 total)
Viewing 2 replies - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.