• Resolved Geldnerd

    (@geldnerd)


    I am looking into WP RSS Aggregator to replace Feedzy. However, when I install and activate it, my 2FAS plugin (version 3.3) reports an incompatibility with WP RSS Aggregator.

    Looking at this support forum I found this post reporting a similar issue, which was closed/’resolved’. Given the report by 2FAS upon installation: Any information as to what the current situation on this incompatibility is?

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Support mikeyboo

    (@mikeyboo)

    Hi @geldnerd, we do not have an update on the incompatibility as this is not something we are able to fix from our end as yet. Would you mind checking with the 2FAS team as well?

    Thread Starter Geldnerd

    (@geldnerd)

    Submitted a question over at the 2FAS team as well.

    Thread Starter Geldnerd

    (@geldnerd)

    Hi @mikeyboo , 2FAS gave me the following reaction: “`This cannot be fixed as long as WordPress’s core is not dependent on dependencies (installed by php Composer dependency manager).
    In short, many plugins use external libraries which come in different versions, e.g. 2FAS Prime and WP RSS use PHP-DI libraries so one of these plugins will not work. We decided that we will not struggle with it anymore and only display an error message (previously, as you mentioned, the user got an error and the whole website did not work properly).
    Besides, you can meet many other plugins that also won’t work because they also use this library.
    In summary, this cannot be solved at the plugin level.`”

    What is your opinion on this?

    Plugin Support mikeyboo

    (@mikeyboo)

    Hi, @geldnerd thanks for the follow-up. The 2FASs team description is accurate as this is not something that can be fixed. However, our dev team confirmed that they will look into an option of removing the dependency in a future release of our plugin.

    Thread Starter Geldnerd

    (@geldnerd)

    Thank you!

Viewing 5 replies - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.