Support » Plugin: 2FAS Prime — Two Factor Authentication » Compatibility issue with WP RSS Aggregator

  • Resolved Geldnerd

    (@geldnerd)


    I am looking into WP RSS Aggregator to replace Feedzy RSS on my site. However, when I install and activate it, my 2FAS plugin (version 3.3) reports an incompatibility with WP RSS Aggregator.

    Looking at the support forum for WP RSS Ag I found this post reporting a similar issue, which was closed/’resolved’. However, given the report by 2FAS upon installation of WP RSS: Any information as to what the current situation on this incompatibility with 2FAS is and how/when it could be resolved?

    Question submitted with the WP RSS Aggregator team as well.

    • This topic was modified 4 months, 3 weeks ago by Geldnerd.

    The page I need help with: [log in to see the link]

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Author 2FAS

    (@2fas)

    Hi,
    This cannot be fixed as long as WordPress’s core is not dependent on dependencies (installed by php Composer dependency manager).
    In short, many plugins use external libraries which come in different versions, e.g. 2FAS Prime and WP RSS use PHP-DI libraries so one of these plugins will not work. We decided that we will not struggle with it anymore and only display an error message (previously, as you mentioned, the user got an error and the whole website did not work properly).
    Besides, you can meet many other plugins that also won’t work because they also use this library.
    In summary, this cannot be solved at the plugin level.

    Thread Starter Geldnerd

    (@geldnerd)

    Thank you for your reply.

Viewing 2 replies - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.