Support » Plugin: RSS Aggregator by Feedzy - Powerful WP Autoblogging and News Aggregator » Cannot edit the widget settings after initial set-up

  • Resolved Geldnerd

    (@geldnerd)


    Release 3.7.3. solved my previous issue.

    However, I found a new one. I have a Feedzy Category containing over 50 RSS feeds from fellow bloggers. When setting up my new blogroll in the sidebar as a Widget with Feedzy 3.7.3, the system gave an error ‘not a valid JSON response’ (In dutch: Er was een fout. De reactie is geen geldige JSON-reactie.) when I try to update the Widget area, and the Feedzy widget is not displaying on my site.

    After much trial and error I found out that I can set up my widget if the Feedzy category contains only 3 RSS feeds. I can change the settings and update the Widget area and the Feedzy widget displays on my website.

    If, after this initial setup, I edit the Feedzy Category and add all my 50 RSS feeds, the widget keeps on working (hurray!) displaying posts from all streams in the category.

    If, however, I revisit the Widgets area and try to change the Feedzy Widget settings, that does not work. When I try to Update the Widgets area the error ‘not a valid JSON response’ shows up again.

    Furthermore, I cannot set a Title for the widget block.`

    The page I need help with: [log in to see the link]

Viewing 3 replies - 1 through 3 (of 3 total)
  • Mat

    (@mateithemeisle)

    Hello @geldnerd,

    Thank you for using Feedzy and for reaching out!

    This might be caused by one of the feeds you are using. I have tested myself on a test instance with about 20 feeds and I encountered no issues.

    Can you please tell us what are the settings you are using in the Feedzy block? Also, try and switch to a different theme (like 2020) and see if the issue is reporducing!

    Make sure when you are implementing the 50 feeds in the category, there is no “,” missing or breaks in the feed url.

    Thank you for looking into this and we’ll wait for your answer!

    Thread Starter Geldnerd

    (@geldnerd)

    Hi Mat, thanks for your reply.

    All feeds passed the ‘Validate & Clean’ test in the Feed Categories, and the widget is not giving any error messages in the sidebar. I have tested all feeds manually just to make sure, and there are no issues with the feeds.

    Feedzy settings: Showing authore, date, time, no images, just the title. Showing 25 items.

    Inbetween, Feedzy upgraded to 3.7.4. Using that version, I cannot reproduce the problem anymore. I will mark it as resolved.

    Hi @geldnerd!

    We are happy to hear the update solved your issue and that everything work properly now!

    Have a nice day!

Viewing 3 replies - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.